Accueil > Linux > Firefox2 sur centos-5.0

Firefox2 sur centos-5.0

Aucun paquet RPM n’existe pour firefox-2 a ma connaissance. J’ai donc décider de décrire la procédure pour installer firefox-2.0 en version binaire en paralelle de firefox-1.5.0.??

Téléchargez firefox : http://download.mozilla.org/?product=firefox-2.0.0.6&os=linux〈=fr

mv /usr/bin/firefox /usr/bin/firefox.1.5.0.?
tar zxvf firefox-2.0.0.tar.gz
mv firefox  /usr/lib/firefox-2.0.x
ln -s /usr/lib/firefox-2.0.4/firefox /usr/bin/firefox
yum install compat-libstdc++-33.i386

Le reste du texte qyui suit je l'ai piqué pour m'en inspiré, je ne me souviens plus de la source.


Then you need to take care of any plugins you have installed ... by
moving them from /usr/lib/mozilla/plugins
and /usr/lib/firefox-1.5.{version}/plugins
to /usr/lib/firefox-2.0.4/plugins/

You need to manage upgrades yourself ... I just download the latest
firefox from mozilla and do this again when there are updates.

Note:  In CentOS-5, firefox is a required install for other things ...
so if firefox-1.5 is installed and updated by yum, you will need to
recreate your /usr/bin/firefox symlink to use firefox 2.

Trying to replace firefox on CentOS-5 with another RPM is going to be
versy problematic as several other packages are built against it in the
distribution ... but running 2 versions in parallel is not very hard.
Categories: Linux Tags:
  1. Pas encore de commentaire
  1. Pas encore de trackbacks
Vous devez être identifié pour poster un commentaire